快速在 Windows 上搭建 Jekyll 开发环境

Jekyll 是一个不错的静态博客工具,本文将提供快速在 Windows 系统上搭建 Jekyll 开发环境的方法。


For 老手

其实所需的命令只有少数几个而已:

# 全局命令:安装 Ruby 所需的依赖
ridk install
# 全局命令:安装 Jekyll
gem install jekyll bundler
# 工作目录命令:安装博客仓库中所需的依赖
bundle install
# 工作目录命令:将本地博客仓库跑起来
jekyll serve

For 新手

下载必要的软件

考虑到我们的网络环境,为了提升本文的阅读效率,建议一边下载一边阅读。我为大家提供两种不同的下载源:1. 官方源;2. 加速源。

  1. 官方源
  2. 加速源(感谢小伙伴林德熙

安装 Ruby 和 Jekyll

  1. 分别安装下载好的 Ruby 和 MSYS2 安装包,一路下一步,直到两者都安装结束;

  2. 一般安装完 Ruby 后会自动弹出一个新的命令行安装界面,我们需要在里面选择 3,然后回车。
    ridk install
    • 如果上一步没有提前下载安装 MSYS2,那么这里会因为众所周知的网络原因速度奇慢无比,或者以失败告终。
    • 如果没有弹出命令行安装界面或者把它关掉了,那么也可以在任意的命令行中输入 ridk install 来再次进入命令行安装界面。
    • 如果网络状况良好,能够一次装成功。(如果不幸失败。则一直再次选 3 继续安装直到全部成功为止。)
       Install MSYS2 and MINGW development toolchain succeeded
      
  3. 再打开一个新的命令行窗口(cmd/powershell/bash/msys2 都行),输入以下命令安装 jekyll:
    gem install jekyll bundler
    

自此,Jekyll 开发环境就搭建完成了。

让自己的博客跑起来

如果你已经有了自己的 Jekyll 博客,希望在本地能够编译运行,那么就继续阅读本节。

可能你的博客来源于这些地方:

那么我们开始。首先在博客的根目录打开命令行,接下来的操作都在命令行中。

  1. 安装依赖包
    bundle install
    
  2. 将 Jekyll 服务跑起来
    jekyll serve
    

这就完成了!

不过,如果上述第 2 个步骤发生了错误,通常是依赖包的版本不匹配所致,运行命令更新依赖包:

bundle update

随后再次 jekyll serve 即可。

Ruby 跨版本升级的坑

如果你之前安装过 Ruby 的旧版本,现在需要跨大版本号升级,那么你会遇到很多问题:

这会导致你试图编译你的博客时遇到各种各样奇怪的错误。

所以,你需要做的是:

本文会经常更新,请阅读原文: https://walterlv.github.io/post/setup-jekyll-in-windows.html ,以避免陈旧错误知识的误导,同时有更好的阅读体验。

知识共享许可协议 本作品采用 知识共享署名-非商业性使用-相同方式共享 4.0 国际许可协议 进行许可。欢迎转载、使用、重新发布,但务必保留文章署名 吕毅 (包含链接: https://walterlv.github.io ),不得用于商业目的,基于本文修改后的作品务必以相同的许可发布。如有任何疑问,请 与我联系